Articles d'aquesta seccióMostra'n més
Configuració del Producte

Com convertir els Favoritos de Archicad per utilitzar la Biblioteca Global en lloc de la Biblioteca Monolítica a l'Archicad?

Convertir els teus Favoritos de Archicad perquè utilitzin la Biblioteca Global en lloc de la Biblioteca Monolítica a l'Archicad 29 facilita la migració de projectes i plantilles creats en versions anteriors.

Nota important: Si inicieu el procés des d'un arxiu de projecte (.PLN), seguiu tots els passos des de 1. Preparació. Si inicieu el procés des d'una plantilla (.TPL), podeu començar des de 2. Exportar Favoritos.

L'eina Favorite Converter és independent de l'idioma de l'Archicad, però només està disponible en anglès.


Guia pas a pas

Pas 1: Preparació

Nota: Aquest pas només és necessari si comenceu des d'un projecte o plantilla amb Biblioteca Monolítica de l'Archicad 27 o anterior.

A partir de l'Archicad 29, la instal·lació del programa ja no inclou la Biblioteca de Migración per defecte.

Cal descarregar-la manualment des del següent enllaç: Descarregar Biblioteca de Migración Archicad 29

Assegureu-vos de seleccionar correctament l'idioma i el sistema operatiu abans de fer la descàrrega.

Un cop descarregat l'arxiu, executeu-lo i seguiu una instal·lació estàndard, fent clic a Siguiente fins finalitzar.

  • Obriu l'Archicad 29 i inicieu un projecte amb la vostra plantilla monolítica de Archicad 27 o anterior.
  • Si la vostra plantilla i la vostra biblioteca són anteriors a Archicad 27, realitzeu primer la migració en iniciar el projecte, prement Migrar Bibliotecas Archicad quan aparegui la finestra de l'Asistente de Migración.
  • Si treballeu a l'Archicad 29 amb un projecte procedent d'una versió anterior, descarregueu i instal·leu també la Biblioteca de Migración de Archicad 29 abans de continuar.
  • Si la vostra plantilla i la vostra biblioteca són d'Archicad 27, la finestra de migració pot seguir apareixent, però podeu ometre aquest pas, ja que la biblioteca d'Archicad 27 continua sent compatible com a punt de partida per a aquest procés.

Pas 2: Exportar Favoritos

  • Obriu la Paleta de Favoritos des de Ventana > Paletas > Favoritos.
  • Feu clic a la roda dentada de la paleta i seleccioneu Importar/Exportar > Exportar....
  • Exporteu els Favoritos a una carpeta nova en format XML.
  • Assegureu-vos que la ruta sigui curta; per exemple: /Users/<Usuario>/Desktop/Archicad27_Favorites.
Exportar favoritos a XML

Pas 3: Descarregar l'eina Favorite Converter

Pas 4: Comprovar que el projecte utilitza Biblioteca Global

Nota: Abans de convertir els Favoritos, convé comprovar que el nou projecte de l'Archicad 29 està carregant la biblioteca en format .libpack, propi de la Biblioteca Global.

  • Obriu un nou projecte amb una plantilla per defecte de Archicad 29. Aquest serà l'arxiu en el qual després importareu els Favoritos convertidos.
  • Aneu a Archivo > Bibliotecas y Objetos > Administrador de Bibliotecas... i comproveu que el contingut de la biblioteca es carrega amb extensió .libpack.
Biblioteca Global amb extensió libpack

Pas 5: Instal·lar i carregar l'extensió Favorite Converter

  • Obriu la carpeta d'extensions de l'Archicad 29 i, si ho necessiteu, creeu una carpeta anomenada Favorite Converter.
  • Copieu o extraieu dins d'aquesta carpeta el contingut descarregat de l'eina.
  • Obriu el Gestor de Extensiones des de Opciones > Gestor de Extensiones.
  • Afegiu l'extensió Favorite Converter a la llista d'extensions disponibles i comproveu que quedi correctament carregada.
Gestor de Extensiones amb Favorite Converter carregat

Pas 6: Convertir Favoritos

  • Obriu Favorite Converter des del menú Opciones.
  • Al primer camp, seleccioneu la carpeta de Favoritos exportats en XML.
  • Al segon camp, trieu la carpeta de destí on es guardaran els Favoritos convertits.
  • Feu clic a Convert i espereu fins que aparegui el missatge Conversion Finished.
Finestra de Favorite Converter

Nota: Els Favoritos que puguin convertir-se automàticament es generaran a la carpeta de sortida. Els que requereixin revisió manual de paràmetres apareixeran llistats a parameter_changes.csv.

Arxiu parameter_changes.csv

Pas 7: Importar els Favoritos convertits

Nota: Aquest pas s'ha de fer sobre el nou projecte que vau obrir anteriorment amb la plantilla per defecte de Archicad 29, és a dir, l'arxiu que ja està treballant amb la Biblioteca Global.

  • Torneu al nou projecte obert amb la plantilla per defecte de Archicad 29.
  • A la Paleta de Favoritos, feu clic a la roda dentada i seleccioneu Importar/Exportar.
  • Trieu l'opció Carpeta (que contiene archivos XML) i feu clic a Importar.
  • Seleccioneu la carpeta generada per l'eina, normalment amb un nom similar a Converted_Favorites_fecha_y_hora.
  • Durant la importació, seleccioneu l'opció Eliminar Todo antes de Importar per eliminar els Favoritos anteriors, ja que no funcionen amb la Biblioteca Global.
Importar favoritos convertits

Comprovació final

Aneu a Archivo > Bibliotecas y Objetos > Administrador de Bibliotecas... i comproveu que totes les parts de la biblioteca s'hagin carregat correctament.

Nota: Un cop importats els Favoritos convertits, ja podreu utilitzar-los amb projectes i plantilles basats en la Biblioteca Global de l'Archicad 29.

Articles relacionats